StrokesPlus Forum
                       
StrokesPlus Forum
Home | Profile | Register | Active Topics
Members | Search | FAQ
 All Forums
 Bug and Issues
 Closed or Unreproducable Bugs
 [CLOSED] StrokePlus and Wireshark

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
Check here to subscribe to this topic.
   

T O P I C    R E V I E W
kobik Posted - 06/16/2013 : 14:19:11
Hi,
I really like S+ but I have a major problem with it.
I'm using Wireshark quite a lot and whenever S+ is active many I can hardly use it.
All problems are related to mouse actions such as clicking buttons, right click on packets, selecting objects and many other issues.
To resolve the problem I have to disable S+.
BTW, I never had such issues using StrokeIt.
Thanks
4   L A T E S T    R E P L I E S    (Newest First)
kobik Posted - 06/17/2013 : 13:24:44
Thank you for your comprehensive explanation.
I guess that being multi-platform application Wireshark contains the receipt for these kind of problems.
Rob Posted - 06/16/2013 : 15:28:13
You'd notice if you did.

Essentially, when checked they improves performance for systems with lower powered GPUs (and prevent some random Windows flickering on XP only). Having a full-screen transparent window (on which the gesture line is drawn) can be GPU intensive as Windows must blend the windows below with the S+ window. On any decent system, you won't notice anything at all with them on or off. So with them unchecked, the S+ gesture window is sent to the bottom of the window stack and hidden, only being made visible and set as topmost while you're drawing a gesture. The only potentially noticeable effect of having these off is if you're doing really fast and short gestures, there can be the slightest delay as the window is being redrawn/blended where you may not see the beginning of a gesture immediately. Like I said, you'll notice if those being off affects you, but there's the full explanation.

In general, they rarely conflicts with anything, so I've left them on by default since it prevents far more people from posting about video related performance issues on their 7 year old Windows XP laptop than the exceptions like yourself who are using a program that doesn't like to behave itself when another window is on top of it, even though transparent and not able to be activated =)
kobik Posted - 06/16/2013 : 15:17:19
Great, that did the trick!
What am I actually losing by un-ticking these options?
Rob Posted - 06/16/2013 : 14:24:06
Have you tried unchecking:

Keep Gesture Draw Window On Top* and Don't hide Gesture Draw Window* in the Preferences tab?

StrokesPlus Forum © 2011-2018 Rob Yapchanyk Go To Top Of Page
Snitz Forums 2000