StrokesPlus Forum
                       
StrokesPlus Forum
Home | Profile | Register | Active Topics
Members | Search | FAQ
 All Forums
 Bug and Issues
 New Bugs
 S+ no longer activated by rt mouse button

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
Check here to subscribe to this topic.
   

T O P I C    R E V I E W
milkchaser Posted - 11/27/2016 : 18:53:16
I don't know what happened. I had edited an action, then S+ just stopped showing up when Right Mouse button is depressed. I just get the normal context menu. I copied my StrokesPlus.xml and StrokesPlus.lua to a temp directory and I reinstalled S+. No change in the behavior.

Any suggestions on how to debug this? Is there a verbose mode? I never realized how dependent I have become on S+.
9   L A T E S T    R E P L I E S    (Newest First)
milkchaser Posted - 11/30/2016 : 00:31:23
I did see that my preferences were probably wiped out, for who knows what reason. But all is back to normal. Whew!

Thanks.
Rob Posted - 11/29/2016 : 23:18:11
But go into your preferences first, check and update your settings first,may be all you need. I've had reports of people having their preferences tab settings wiped out. If the match stuff is 0, then this happened to you. See the example on the screenshot on the main Web page and match those, see if it works.
milkchaser Posted - 11/29/2016 : 23:17:00
Clean install seems to be working.

I think what I did wrong before was trying to reinstall without deleting the config files in my AppData/Roaming/StrokesPlus folder. Or maybe I did, but I forgot to close StrokesPlus first and when it exited, it wrote bad data into those files again.

But this time I deleted the program files and the config files. And I will recreate my actions from scratch. There is definitely something in one of my old scripts however that crashes S+ real hard. :-(
Rob Posted - 11/29/2016 : 23:14:25
The install won't overwrite,in an attempt to not overwrite your gestures, etc.
Rob Posted - 11/29/2016 : 23:13:37
Your configuration file may have gotten messed up. If you delete your StrokesPlus.xml, then reinstall it will be fresh.
milkchaser Posted - 11/29/2016 : 23:11:25
I think the problem must be with the data files. I can get S+ to run, even with only one instance. But it seems to want to put up the dialog about running as Admin every time and it has no actions. But at least it draws the gestures.

However, when I substitute my old S+.xml, the gestures go away. Interesting point, though: If I put S+ in training mode, it recognizes and records my gestures, but does not draw.

At this point, I am just trying to get back to a clean install.
Rob Posted - 11/29/2016 : 22:38:34
The "crafty or senile" prompt means S+ is already running, so you're attempting to run S+ twice, which is possible, but can cause conflicts. If S+ is running after you start it again and you see the drawings, it means the other original instance has a messed up configuration. Though, I'm a bit drunk st the moment, so probably not in the best state of mind :)
milkchaser Posted - 11/29/2016 : 20:37:37
After reinstalling, StrokesPlus appears in TaskManager, but it seems to be displaying a dialog named "Admin". I say this because there is a line under the StrokesPlus task in TaskManager that shows a dialog box icon and the word "Admin".

However, I cannot bring this dialog to the front. But when I run StrokesPlus a second time (even though it is already running), the dialog comes to the front. It is named "Admin" and it states:
quote:
Beginning with version 2.2.1, StrokesPlus no longer requires Administrator privileges to run. For most uses, this is acceptable.... If you run the signed version of S+ from a protected folder (Program Files) in Windows 8, these issues can be avoided.


StrokesPlus is installed under C:\Program Files (in a 64-bit Win10).

After clicking OK on the "Admin" dialog, I get a second dialog named "Crafty or just senile?" :-) that states:
quote:
StrokesPlus is already running. Click Yes if you really intend to run another instance of StrokesPlus.


If I click Yes, S+ does respond to Rt Button drag by drawing the familiar S+ blue line. When I bring up the S+ preferences dialog, there are no actions, no hotkeys, not much of anything.

I am going to try to reinstall again.
Rob Posted - 11/27/2016 : 19:43:48
Try deleting your S+ files, reinstalling won't overwrite them, to preserve settings. See if that works, you can also email me your files (if there's no sensitive info stored) to rob@strokesplus.com and I can take a look.

StrokesPlus Forum © 2011-2018 Rob Yapchanyk Go To Top Of Page
Snitz Forums 2000