StrokesPlus Forum
                       
StrokesPlus Forum
Home | Profile | Register | Active Topics
Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Lua Scripts
 General Action Scripts
 Stoke+ not always active.
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

mesersmith

Romania
41 Posts

Posted - 06/12/2015 :  16:04:05  Show Profile  Reply with Quote
I have a very frustrating situation with Stroke+
And because this sotware is the heart of all my pc and because I can't work witout it for several years, I have to find a solution.
So, from time to time, Stroke+ is just not working. It stays on taskbar, the re circle is not on it, but when I make the gesture, it just don't do it.
I use Stroke+ on my home laptop wich has win7 and to another laptop from work wich has 7 also.

Please, can we find what's happening with stroke?
I install a clean copy of windows, I install xp, 7, 8, 10 on different laptops, but I get the same reaction.

To make it work, I have to press once on the icon in taskbar and after the red circle appear on icon, I press again. The circle disappear and then works great for a cupple of minutes.

Rob

USA
2573 Posts

Posted - 06/16/2015 :  09:36:20  Show Profile  Visit Rob's Homepage  Reply with Quote
I'm not why you're encountering that issue. I use S+ at work and home, on multikple machines and have never had an issue. When you install a clean version, are you using the default StrokesPlus.xml config file? Or are you replacing it with your own config? If you're replacing, perhaps try using the default config for a while and see if it still happens.

The only other thing I can think of is that there's some other program/driver that's installing a mouse hook and it's interfering with S+, but there's no easy way for me to determine that.
Go to Top of Page

mesersmith

Romania
41 Posts

Posted - 06/30/2015 :  15:12:15  Show Profile  Reply with Quote
Yes,I always replase the xml file in AppData with one in wich I have save my own gesture.
I do this because I have almost all gesture different from the ones in default.
But now I put a new copy oh windows on my machine and S+ just wont start. I tried with administrator rights. Same behavior. And just beleve me, I can't use any pc without my gesture.

StrokePlus Executable has stopped workig.

Problem signature:
Problem Event Name: APPCRASH
Application Name: StrokesPlus.exe
Application Version: 2.7.4.0
Application Timestamp: 5212f6c5
Fault Module Name: StrokesPlus.dll
Fault Module Version: 2.7.4.0
Fault Module Timestamp: 5212f6c0
Exception Code: c0000005
Exception Offset: 000a16b5
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt
Go to Top of Page

Rob

USA
2573 Posts

Posted - 06/30/2015 :  15:27:38  Show Profile  Visit Rob's Homepage  Reply with Quote
I see you're running an older version. Would you mind trying the latest?

Application Version: 2.7.4.0
Go to Top of Page

mesersmith

Romania
41 Posts

Posted - 06/30/2015 :  15:45:57  Show Profile  Reply with Quote
I tried 2.8.3.3 for 64 bits. Same behavior.
What a hell is happening? I refuse to work without my gesture. I do this for many years.
Is there a new version higher than 2.8.3.3?
What is the latest version?

Edited by - mesersmith on 06/30/2015 15:49:38
Go to Top of Page

Rob

USA
2573 Posts

Posted - 06/30/2015 :  19:56:11  Show Profile  Visit Rob's Homepage  Reply with Quote
Unfortunately, there's no way for me to debug this from my computer. I (obviously) use S+ on 2 computers at home and 2 computers at work every day and do not have any issues. Also, no one else has posted anything about having the issues you are experiencing. There's certainly something going on, but there is no simple solution I can suggest. Perhaps try disabling all other applications from running and see if things work, then enabling other apps one by one until you start having the problems again.

Or your it may be that there is some hardware driver which is interfering with S+; possibly a touchpad or touchscreen driver since you mention laptops. There are so many possibilities...but without sitting at your machine, there's little I can do to try to help.

I'm not sure if anything useful will show up, but you can try downloading DebugView and running this debug version of S+. You run DebugView first, then start the debug version of S+. However, the debug logging really slows down S+ and the system, so it may not really be feasible or practical, but it's the best suggestion I can come up with at the moment.
Go to Top of Page

mesersmith

Romania
41 Posts

Posted - 07/01/2015 :  11:57:45  Show Profile  Reply with Quote
When I run debbug S+, I get this in Debbug view.
I really don't know what this mean, but in the end of this code, I see something about Touchpad.



[4736] In DLL_PROCESS_ATTACH
[4736] About to init DLL resources
[4736] About to register Scintilla
[4736] About to attempt to resolve IsImmersiveProcess
[4736] About to attempt to resolve monitor brightness functions
[4736] About to get mutex
[4736] About to set DPI
[4736] About to init global strings
[4736] About to register class
[4736] About to set current path
[4736] About to check for config file along side EXE
[4736] Nope, get from %appdata%
[4736] About to call InitInstance
[4736] About to set OS version
[4736] About to loadHookConfig
[4736] In loadHookConfig
[4736] About to open lang file
[4736] About to open config file
[4736] About to see if we need to prompt for password
[4736] About to call read_xml for main config
[4736] About to delete copied file (when password exists)
[4736] About to load all settings
[4736] Enter setWindowState
[4736] About to set draw window as topmost (if setting active)
[4736] About call read_xml for action help
[4736] About to load hotkeys
[4736] About to test and load for Synaptics
[4736] Synatpics Enabled
[4736] mSynaptic == NULL
[4736] SynCtrl.SynAPICtrl Found
[4736] TouchPad: Init()
Go to Top of Page

mesersmith

Romania
41 Posts

Posted - 07/01/2015 :  12:03:18  Show Profile  Reply with Quote
And yes, I installed the touch driver and now S+ works great.
More than that, when I first start S+, it tell me that it is not compatible with touch pad driver, wich will be closed.
Thanks for your answer, you made my day.
Go to Top of Page

Rob

USA
2573 Posts

Posted - 07/01/2015 :  12:10:52  Show Profile  Visit Rob's Homepage  Reply with Quote
I'm glad to hear it's working now!
Go to Top of Page

mesersmith

Romania
41 Posts

Posted - 07/01/2015 :  12:20:48  Show Profile  Reply with Quote
Thanks a lot! Do you belive me that when I work on any pc, mine or my friends pc, I go to my cloud account, download S+ and my xml version and then I start to work on pc?
Great job!
Go to Top of Page

Rob

USA
2573 Posts

Posted - 07/01/2015 :  12:24:21  Show Profile  Visit Rob's Homepage  Reply with Quote
I believe you. Once you get used to gestures, there's no going back
Go to Top of Page

BladeMight

6 Posts

Posted - 03/19/2016 :  12:00:55  Show Profile  Reply with Quote
Yeah, gestures are best!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
StrokesPlus Forum © 2011-2018 Rob Yapchanyk Go To Top Of Page
Snitz Forums 2000