StrokesPlus Forum
                       
StrokesPlus Forum
Home | Profile | Register | Active Topics
Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 General Discussion
 General Discussion
 ForegroundLockTimeout
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

paninaro95

Germany
3 Posts

Posted - 04/09/2018 :  14:02:26  Show Profile  Reply with Quote
Hello!

I have actually a very simple question: why does StrokesPlus set the value of "ForegroundLockTimeout" to 0?

You can read about this Windows setting here:

https://technet.microsoft.com/en-us/library/cc957208.aspx

If I set it back to its default value, StrokesPlus works as fine as before.

Am I missing something?

Markus

Rob

USA
2514 Posts

Posted - 04/09/2018 :  14:24:38  Show Profile  Visit Rob's Homepage  Reply with Quote
This is to help ensure that S+ can make other programs the active window, instead of having the taskbar button for the application flash orange.

I do other things to also help prevent this issue, but this is another of those tactics. Windows makes it very difficult (on purpose) for applications to switch or steal focus. This was introduced many years ago when "bad" programs would force themselves to the foreground and in full screen mode, blocking you from being able to get out of them.
Go to Top of Page

paninaro95

Germany
3 Posts

Posted - 04/12/2018 :  04:17:57  Show Profile  Reply with Quote
Well, could you make this an option please?

My primary use of S+ is to maximize a window vertically, to minimize or close it.

So in my case, there is no need for S+ to make another window the active one.

I found it pretty annoying that other windows suddenly are in the foreground while I was working in another application.
Go to Top of Page

Rob

USA
2514 Posts

Posted - 04/12/2018 :  05:53:44  Show Profile  Visit Rob's Homepage  Reply with Quote
Unfortunately, I'm no longer doing active development on S+, focusing my free time instead on StrokesPlus.net. However, I will add it as an option in the new version.

In the meantime, the only workaround I can suggest is to edit your StrokesPlus.xml file (either alongside StrokesPlus.exe, or in C:\Users\{USERNAME}\AppData\Roaming\StrokesPlus. Search for "CheckForegroundTimeout" and replace the value with 1, so it looks like this:

<CheckForegroundTimeout>1</CheckForegroundTimeout>

This is a hidden option, which wasn't really intuitively named, but essentially if the foreground timeout is not 0 (what S+ wants to set it to), it will prompt you to ask whether or not you want S+ to update the setting. This prompt would show each time S+ is started, so perhaps annoying in a different way, but it will allow you to click "No" and it should leave the foreground timeout setting alone.
Go to Top of Page

paninaro95

Germany
3 Posts

Posted - 04/13/2018 :  05:35:42  Show Profile  Reply with Quote
Thanks for the explanation. But clicking that message box away will be also very annoying.

I will then go for a scheduled task that will restore the original/default value of ForegroundLockTimeout, either after start-up of S+ or periodically ;-)

But great that you consider making it an option eventually. Thank you!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
StrokesPlus Forum © 2011-2018 Rob Yapchanyk Go To Top Of Page
Snitz Forums 2000