StrokesPlus Forum
                       
StrokesPlus Forum
Home | Profile | Register | Active Topics
Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 General Discussion
 General Discussion
 "Ignoring gestures" after unlocking
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Daniel Beardsmore

United Kingdom
4 Posts

Posted - 07/25/2018 :  05:40:07  Show Profile  Visit Daniel Beardsmore's Homepage  Reply with Quote
Sometimes, StrokesPlus goes into ignore mode after locking and unlocking my PC. This has been a problem with every version of Windows 10 in over a year.

The tray icon shows the disabled icon, but its tooltip reports something like "StrokesPlus - Ignoring Gestures".

I found that exact caption from Github; I felt sure I'd seen an explanation somewhere for this, but now Google suggests I imagined that -- as I recall, it was something in Explorer that it was ignoring.

I can either manually disable and re-enable StrokesPlus, or seemingly just wait (until you do whatever it is that triggers it to come back). Does anyone recognise this symptom and know of a way to automatically force S+ to work correctly?

All I had in the ignore list was the default, of "Taskbar" (owner claass = Shell_TrayWnd). I've just added two more: owner class WorkerW (to avoid inadvertently minimising the desktop as you can't get that back and it scrambles your icons) and owner class = Shell_SecondaryTrayWnd just in case).

As it seems to self rectify, I don't know how frequent this is as I only notice if I try to use a gesture right after unlocking my PC.

Rob

USA
2492 Posts

Posted - 07/25/2018 :  09:11:23  Show Profile  Visit Rob's Homepage  Reply with Quote
This is a "feature" to address issues during a resume process (including unlocking), to ensure the screens have been initialized before resizing the S+ gesture drawing surface. If S+ doesn't have the draw surface cover the entire screen, things will get very wonky. This was something I added very early on, 6 years ago. Since then, PCs have gotten much faster, especially with SSDs now being very common.

Open your StrokesPlus.xml file (either in the S+ directory, or {system_drive}\{username}\{appdata}\Roaming\StrokesPlus).

Find "<ResumeDelay>", by default it's 5000 (5000 ms, 5 seconds), replace with a lower value that doesn't cause you any problems. I would recommend having something > 0, but 5000ms is probably very long for an average PC nowadays.

To be safe, exit S+ before editing the file.
Go to Top of Page

Daniel Beardsmore

United Kingdom
4 Posts

Posted - 07/26/2018 :  12:07:20  Show Profile  Visit Daniel Beardsmore's Homepage  Reply with Quote
What is this delay measured from the time that unlock is completed, or the time that the computer begins sending a video signal and shows the password prompt?

Could anything cause the delay to be much longer? By the time I've made a number of attempts to use gestures, and realised that gestures have stopped working, and gone into the tray and found that it's set to "Ignoring Gestures" (and the icon sits there and does not change), I'd have thought that at least 1020 seconds must have passed since the point that unlock has completed.

ResumeDelay for me is on its default of 5000.

It's also intermittent. Locking does not trigger ignore mode, so I guess that ignore mode only begins when the machine enters video power down.

If it helps, the PC is left on permanently, but it does go into video power down after ~20 minutes. I guess I need to check each time I come back and unlock when the screens were in standby.

(It's too late to fix this now, but certainly for the future the program should use a different tray icon for ignoring vs disabled, as it was never clear to me why it was getting disabled but yet not ticked as disabled. Maybe the icon should animate, like show a Chrome download progress ring in the disabled circle, showing when it will come back.)
Go to Top of Page

Rob

USA
2492 Posts

Posted - 07/26/2018 :  13:08:21  Show Profile  Visit Rob's Homepage  Reply with Quote
I'm honestly not sure what would be causing it to be stuck in ignoring. One possibility is that your Control key is your ignore, and maybe you're using Ctrl+Alt+Delete to lock your PC? If it picked up the Control key it would set itself to ignore until Control was released, however once Alt+Delete are added to keys, Windows takes over and wouldn't send the Control Key Up event, possibly leaving S+ stuck in ignore mode.

Regarding the new version, it doesn't use a silly timer, it just has events bound to SystemEvents.DisplaySettingsChanging and SystemEvents.DisplaySettingsChanged and responds accordingly. So there's no arbitrary delay; it reacts with the OS in real time.
Go to Top of Page

Rob

USA
2492 Posts

Posted - 07/26/2018 :  13:12:06  Show Profile  Visit Rob's Homepage  Reply with Quote
Oh, and there are actually two different events in play. WM_DISPLAYCHANGE (when the display changes, actually has a hard-coded 2 second delay), and WM_POWERBROADCAST for when it changes power saving modes (like when the screen goes off and comes back on).

Either way, they both look to see if gestures are disabled, which would be the case if the Control key thing I mentioned above happened.
Go to Top of Page

Daniel Beardsmore

United Kingdom
4 Posts

Posted - 07/26/2018 :  13:18:09  Show Profile  Visit Daniel Beardsmore's Homepage  Reply with Quote
I did have Control set, but I use Win+L for lock. I've just removed the Control anyway as I never use that, and with a five-button mouse I don't need to anyway.

Ignore definitely seems to time out, but just longer than five seconds, as this time around it went away in a minute or less. Next time it happens I will have to pay more attention to the timeframe involved.

I'll see what happens. Cheers.
Go to Top of Page

Daniel Beardsmore

United Kingdom
4 Posts

Posted - 07/27/2018 :  02:39:59  Show Profile  Visit Daniel Beardsmore's Homepage  Reply with Quote
Just to be sure, this morning I went to the PC, woke up the screens, unlocked it, and S+ was fine. I don't think this problem occurs all the time it seems to be triggered by something. (Someone before mentioned it was to do with ignoring Explorer, but I forget what I read or where, but there was some suggestion.)

(Maybe that control key change fixed it.)
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
StrokesPlus Forum © 2011-2018 Rob Yapchanyk Go To Top Of Page
Snitz Forums 2000