This App is No Longer Maintained. Visit the Replacement at

StrokesPlus Forum
StrokesPlus Forum
Home | Profile | Active Topics
Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 Bug and Issues
 New Bugs
 [OPEN] acSendKeys not working in Photoshop CC
 Forum Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  


2 Posts

Posted - 09/11/2013 :  18:12:48  Show Profile
Similar to this post, I cannot get S+ to send keys like ^c for copy to the latest Photoshop. It works in non-WinTab applications it seems.

Unlike the afore linked post, the workaround using acDelay does not work. Also, curiously, I tried gMote, and it is able to send keys to Photoshop CC.

Anyone else experiencing this problem? I'm running Windows 8.1 x64. Maybe somebody could test Photoshop on Windows 8 and see if this is an 8.1 related issue.

Thanks a lot and great program by the way! Especially for Tablet PC users.

Edited by - marty on 09/11/2013 18:13:15


2615 Posts

Posted - 09/11/2013 :  23:10:45  Show Profile  Visit Rob's Homepage
Hmm, I have Photoshop CS6 on Windows 8 x64 and both acSendKeys("^c") and acSendKeys("^v") work fine. Not sure what is different between CS6 and CC.

Do you have any kind of window activating script, like in sp_before_action? Some people want to activate a window first, but I don' case that has any effect.

If I get some free time, I'll download the CC trial in a VM and see if I can find anything.
Go to Top of Page


2 Posts

Posted - 09/12/2013 :  03:04:12  Show Profile
I haven't modified the default settings of S+ in anyway except to add a few gestures and change which keys are being sent via acSendKeys. I don't have any other commands or scripts besides acSendKeys in the Lua Script box.

Just a small note, it's not just modified keys like ^c, it's any key at all. I can't send Delete, Enter, Tab, etc. But it's working just fine in app like Notepad, Chrome, Excel. It's just in Photoshop CC (and other CC apps like Illustrator) that it's not working.

EDIT: I did another test and found something interesting. I tried get acMinimizeWindow to activate inside Photoshop and didn't work, but it's working in other apps. So, it looks like Photoshop CC isn't receiving any commands at all from S+.

Edited by - marty on 09/12/2013 03:11:33
Go to Top of Page
  Previous Topic Topic Next Topic  
 Forum Locked
 Printer Friendly
Jump To:
StrokesPlus Forum © 2011-2018 Rob Yapchanyk Go To Top Of Page
Snitz Forums 2000